Ne razumijem se bash u routing pa bi mi trebala vasa pomoc. A kasnije kada ovo proradi napravio bi sazetak ove teme u jedan howto koji bi mogao da se okaci kao sticky thread.
Opis problema:
Na net idem iz studentskog doma i problem je sto smo ograniceni sa protokom od 60kbps po ip adresi. Postavio sam slackware server u mrezu i sad hocu preko quagga da namjestim dinamicki routing da moj komp korisiti 2 rute, "mojkomp>network gateway>internet" i "mojkomp>slackserver>network gateway>internet". Postoji li mogucnost da podesim quagga router tako da mi spaja ta 2 linka? Znaci 60kbps+60kbps=120kbps ili je samo moguce da ih koristim posebno? Npr. skidam 2 fajla, jedan idem preko prve rute 60kbps i kad krenem drugi da skidam on ide preko druge rute isto 60kbps?
internet
|
router(gateway 192.168.0.250)
| \
192.168.1.84(mojkomp) 192.168.1.30(slackserver)
|--------------------------backbone----------------|
10.10.11.1(mojkomp virtual interface eth0:0) 10.10.11.3(slackserver virtual interface eth0:0)
Koliko sam skontao trebaju mi daemons zebra, bgpd i ospfd i to sve na mom kompu a na slackserver samo treba da ukljucim routing izmedju 2 interface-a eth0 i eth0:0. Ili grijesim?
Evo conf fajlova:
Code:
root@papastrumpf:/usr/local/etc# cat zebra.conf
! -*- zebra -*-
!
hostname papastrumpf
!password hehe
enable password hehe
!
! Interface's description.
!
interface eth0
no shutdown
ip address 192.168.1.84/32
link-detect
interface eth0:0
no shutdown
ip address 10.10.11.1/32
link-detect
line vty
no login
log stdout errors
log file /var/log/quagga/zebra.log
root@papastrumpf:/usr/local/etc# cat zebra.conf
! -*- zebra -*-
!
hostname papastrumpf
!password hehe
enable password hehe
!
! Interface's description.
!
interface eth0
no shutdown
ip address 192.168.1.84/32
link-detect
interface eth0:0
no shutdown
ip address 10.10.11.1/32
link-detect
line vty
no login
log stdout errors
log file /var/log/quagga/zebra.log
Code:
root@papastrumpf:/usr/local/etc# cat bgpd.conf
!
hostname papastrumpf
bgp config-type cisco
password hehe
enable password hehe
!interface eth0
! ip address 192.168.1.84/32
! no shutdown
! link-detect
!
!interface eth0:0
! ip address 10.10.11.1/32
! no shutdown
! link-detect
router bgp 64584
bgp router-id 192.168.1.84
no synchronization
redistribute ospf
neighbor 10.10.11.3 remote-as 64530
neighbor 192.168.1.84 remote-as 64584
no auto-summary
line vty
no login
root@papastrumpf:/usr/local/etc# cat bgpd.conf
!
hostname papastrumpf
bgp config-type cisco
password hehe
enable password hehe
!interface eth0
! ip address 192.168.1.84/32
! no shutdown
! link-detect
!
!interface eth0:0
! ip address 10.10.11.1/32
! no shutdown
! link-detect
router bgp 64584
bgp router-id 192.168.1.84
no synchronization
redistribute ospf
neighbor 10.10.11.3 remote-as 64530
neighbor 192.168.1.84 remote-as 64584
no auto-summary
line vty
no login
Code:
root@papastrumpf:/usr/local/etc# cat ospfd.conf
! -*- ospf -*-
!
hostname papastrumpf
password hehe
enable password hehe
router ospf
router-id 192.168.1.84
redistribute connected
network 10.10.11.0/24 area 0.0.0.0
network 192.168.0.0/16 area 0.0.0.10
line vty
no login
log stdout errors
log file /var/log/quagga/ospfd.log
root@papastrumpf:/usr/local/etc# cat ospfd.conf
! -*- ospf -*-
!
hostname papastrumpf
password hehe
enable password hehe
router ospf
router-id 192.168.1.84
redistribute connected
network 10.10.11.0/24 area 0.0.0.0
network 192.168.0.0/16 area 0.0.0.10
line vty
no login
log stdout errors
log file /var/log/quagga/ospfd.log
conf fajlovi su sintaksno u redu, pri pokretanju demona ne javljaju se greske vezane za conf fajlove, ali mi javlja ovu gresku zebra.
Code:
root@papastrumpf:/usr/local/etc# zebra -d
Can't up interface
root@papastrumpf:/usr/local/etc# ps -ef |grep zebra
root 19197 15658 0 15:11 pts/7 00:00:00 grep zebra
root@papastrumpf:/usr/local/etc# ifconfig
eth0 Link encap:Ethernet HWaddr 00:19:b9:54:8c:7e
inet addr:192.168.1.84 Bcast:192.168.255.255 Mask:255.255.0.0
inet6 addr: fe80::219:b9ff:fe54:8c7e/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:625786 errors:0 dropped:0 overruns:0 frame:0
TX packets:577887 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:565438840 (539.2 MiB) TX bytes:334104940 (318.6 MiB)
Interrupt:18
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:200 (200.0 B) TX bytes:200 (200.0 B)
root@papastrumpf:/usr/local/etc# zebra -d
Can't up interface
root@papastrumpf:/usr/local/etc# ps -ef |grep zebra
root 19197 15658 0 15:11 pts/7 00:00:00 grep zebra
root@papastrumpf:/usr/local/etc# ifconfig
eth0 Link encap:Ethernet HWaddr 00:19:b9:54:8c:7e
inet addr:192.168.1.84 Bcast:192.168.255.255 Mask:255.255.0.0
inet6 addr: fe80::219:b9ff:fe54:8c7e/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:625786 errors:0 dropped:0 overruns:0 frame:0
TX packets:577887 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:565438840 (539.2 MiB) TX bytes:334104940 (318.6 MiB)
Interrupt:18
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:200 (200.0 B) TX bytes:200 (200.0 B)
a kada podignem interface rucno
Code:
ifconfig eth0:0 10.10.11.1/24 up
ifconfig eth0:0 10.10.11.1/24 up
ne javi mi gresku Can't up interface, ali se ni daemon ne pokrene.
Moze malo smjernica sta kako kuda?

hvala
[Ovu poruku je menjao kefalo dana 25.06.2008. u 15:32 GMT+1]